使用方法

  • 请在脚本开头插入 local ts = require("ts") 即可调用扩展库中所有函数。

  • iOS 11 以下系统设备需要放到如下路径:/var/mobile/Media/TouchSprite/plugin,标准版和专业版可以在「更多」→「文件管理」→「插件」中直接下载。

  • iOS 11 及其以上系统设备放到如下路径:/var/mobile/Media/TouchSprite/plugin_ios11/ 或者 usr/bin/tsplugin/,标准版和专业版可以在「更多」→「文件管理」→「插件」中直接下载。

  • 安卓版和模拟器版 ts.so 需要放到如下路径:data/data/com.touchsprite.android/files/plugin,普通版可以在「我的账号」 →「文件管理」 →「插件」中直接下载。

  • 安卓设备找不到该目录时需要使用第三方文件管理器,推荐 RE文件管理器

  • Android 真机与模拟器 ts.so 文件不同,需要按照设备类型进行下载。

  • 引擎版本:Androidv3.1.7.1、iOSv3.1.1 及其以上版本已支持 TSP 脚本多平台调用文件,具体内容详见扩展阅读-TSP 脚本根据运行环境释放文件

注意事项

模拟器版部分功能不支持,请自行尝试

  • 安卓和 iOS 部分函数调用方法不同,请仔细参考
  • 下载新的扩展库后需要重启触动服务才能生效

函数扩展库下载

平台 版本 备注 更新日期 使用方法
iOS v1.4.0 仅支持标准版 v3.0.3、
专业版 v3.0.4 及以下版本;
企业版没有限制客户端版本;
没有限制设备系统
2019-06-27 请仔细查看上方使用方法
iOS v1.4.2 仅支持标准版 v3.0.4、
专业版 v3.0.5 及以上版本;
企业版没有限制客户端版本;
没有限制设备系统
2019-07-19 请仔细查看上方使用方法
iOS v1.4.3 仅支持标准版 v3.0.4、
专业版 v3.0.5 及以上版本;
企业版没有限制客户端版本;
没有限制设备系统
2020-01-01 请仔细查看上方使用方法
安卓真机 v1.1.1 适用于触动安卓 v2.2.x 及更低版本 2018-07-17 请仔细查看上方使用方法
安卓模拟器 v1.1.1 适用于触动安卓 v2.2.x 及更低版本 2018-07-17 请仔细查看上方使用方法
安卓真机 v1.1.1 适用于触动安卓 v2.3.0 - v3.1.0 版本 2018-07-17 请仔细查看上方使用方法
安卓模拟器 v1.1.1 适用于触动安卓 v2.3.0 - v3.1.0 版本 2018-07-17 请仔细查看上方使用方法
安卓真机 v1.1.4 适用于触动安卓 v3.1.1 及以上版本 2020-01-01 请仔细查看上方使用方法
安卓模拟器 v1.1.4 适用于触动安卓 v3.1.1 及以上版本 2020-01-01 请仔细查看上方使用方法
Copyright 北京帮你玩科技有限公司 2020 all right reserved,powered by Gitbook该文章修订时间: 2020-07-03 18:06:04

results matching ""

    No results matching ""