函数:compareVersion 比较版本号

函数名称:比较版本号

函数功能:比较版本号大小

TSLib 版本:仅支持 v1.2.9 及其以上版本

函数方法

size = compareVersion(v1,v2)

参数 类型 字段 说明
v1 string 必填 需要比较的版本号,参数需要大于 0
v2 string 必填 需要比较的版本号,参数需要大于 0
返回值 类型 说明
size string 如果 v1 大于 v2 返回 1,如果 v2 大于 v1 返回 2,v1 与 v2 相同返回 3

脚本示例:

require("TSLib")
local m = TSVersions()
if m <= "1.2.8" then
    dialog("请使用 v1.2.9 及其以上版本 TSLib")
     luaExit()
end
--注意:仅支持 TSLib v1.2.9 及其以上版本
dialog(compareVersion("1","10"))
Copyright 北京帮你玩科技有限公司 2020 all right reserved,powered by Gitbook该文章修订时间: 2020-02-04 15:15:22

results matching ""

    No results matching ""